Results 1 to 10 of 10

Thread: DJI Naza attitude mode problem

  1. #1
    Pilot Extraordinaire kyrkbymannen's Avatar
    Join Date
    Sep 2012
    Location
    Sweden
    Posts
    71
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    DJI Naza attitude mode problem

    Hello,

    I have built a hexacopter with a DJI Naza controller.
    It's got a DJI Hexacopter frame but with the following setup

    DJI Naza + GPS
    Hobbywing Pentium ESC
    Turnigy Propdrive 35-30 1100 KV (very strong)
    10x5 props which i've balanced a bit.

    The problem i have, although it flies excellent in manual mode, i cannot use the attitude mode, it climbs and drops and climbs and drops... and not a small amount either, atleast 2 - 3 meters. I have tried a bunch of gain settings,but i'm not sure the gain is the problem.
    I got me a program card for the ESC's , but i dont know if timing or break on off will make a difference?

    Anyone with experience in this?

    Thanks!

  2. #2
    Aerial DP kloner's Avatar
    Join Date
    Jan 2012
    Location
    San Diego
    Posts
    8,218
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    is it mounted out in the light? it sounds like the barometer light problem, black tape on the left side mod thinga ma jiggy

    http://www.multirotorforums.com/show...=barometer+sun
    Member of MPAA, Local 600 DP - N522QZ & N147BW
    Aerial MOB is proud to use products from:KlonerBuilt, Red Digital Cinema, Panasonic Lumix, Aeronavics, Hexacrafter, Team Blacksheep, Ritewing, Photohigher....instagram, facebook.... #klonersfpv #klonerbuilt #aerialmob --- Support your Local 600 ---

  3. #3
    Full Blown Hucker DesJardins's Avatar
    Join Date
    Aug 2012
    Location
    Arizona
    Posts
    709
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Kloner nailed it before I could
    TBS Discovery FPV Quad (DJI Naza & GPS)
    T-motors (MT-2216-11) 900Kv, Graupner 9" Props
    Futaba 8FGs & (S.bus) R6208SB

    PowerLab6 & Pulse "3S" 45C Lipos

    TBS69 FPV cam & GoPro Hero2, ImmersionRC 600mW 5.8GHz Tx, 5.8 GHz Circular Wireless Omni Skew Planar Wheel Tx/Rx Antenna set, Fat Shark Dominator goggles, Fat Shark 5.8GHz (-90dB) Rx module.

    http://www.youtube.com/user/desjardinsj

  4. #4
    Pilot Extraordinaire kyrkbymannen's Avatar
    Join Date
    Sep 2012
    Location
    Sweden
    Posts
    71
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi guys,

    Thanks for the response.

    It is mounted in the middle of the frame so it's a low risk sunlight hit the Naza.
    To give a better "error description" and test your theory, i just went out and tested it in pitch black, and rather cold sweden.
    I also set the X2 to my DX8 knob to try playing with the gains on the barometer inflight.

    To my surprise it did not climb and descend, perhaps because i loaded it with an 8000 mah heavy battery...
    Anyway, i hovered for a minute without issues, but i found out... flying sideways, no problem, but when i fly forward, it descend rather quickly, and when i pull back, it stop descending.

    I checked my calibration on my radio and there is no "misfortunate" mixing or anything going on.
    I have a geniuine F550 which i have exact the same settings on, which never loose altitude so there is something with this guy.
    Everything is brand new, so i suspect there is a compability issue with the ESC's, because it's a bit edgy because of the powerful motors.

    I'm out of ideas .

  5. #5
    Full Blown Hucker DesJardins's Avatar
    Join Date
    Aug 2012
    Location
    Arizona
    Posts
    709
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It's what Kloner said... It happened to me as well, if you don't cover and test in sunlight you won't know and even being in the frame doesn't matter as it takes literally a smidgen of direct sunlight.

    Multi rotor can lower while your flying forward, part of the learning throttle control in wind and it shouldn't just drop

    Also when you hit "write" in the Tx calibration screen did you make sure the throttle stick was also centered (showing green) upon hitting the "write" button?
    TBS Discovery FPV Quad (DJI Naza & GPS)
    T-motors (MT-2216-11) 900Kv, Graupner 9" Props
    Futaba 8FGs & (S.bus) R6208SB

    PowerLab6 & Pulse "3S" 45C Lipos

    TBS69 FPV cam & GoPro Hero2, ImmersionRC 600mW 5.8GHz Tx, 5.8 GHz Circular Wireless Omni Skew Planar Wheel Tx/Rx Antenna set, Fat Shark Dominator goggles, Fat Shark 5.8GHz (-90dB) Rx module.

    http://www.youtube.com/user/desjardinsj

  6. #6
    Aerial DP kloner's Avatar
    Join Date
    Jan 2012
    Location
    San Diego
    Posts
    8,218
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    if that throttle cali part is off or if the trim slider is anything but in the middle the radio can cause a drop. Also CG being off can make it drop

    if this naza has a little red light inside the big naza box, i'd get tape on it asap. mine is in teh middle too, but light form the side really made mine fall, like a rock, and alot of other peoples. Red light seems to be a common indicator. it's just a version of the naza from best we can tell, the newest ones like buy it today
    Member of MPAA, Local 600 DP - N522QZ & N147BW
    Aerial MOB is proud to use products from:KlonerBuilt, Red Digital Cinema, Panasonic Lumix, Aeronavics, Hexacrafter, Team Blacksheep, Ritewing, Photohigher....instagram, facebook.... #klonersfpv #klonerbuilt #aerialmob --- Support your Local 600 ---

  7. #7
    Pilot Extraordinaire kyrkbymannen's Avatar
    Join Date
    Sep 2012
    Location
    Sweden
    Posts
    71
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for all answers.

    What i'm going to do is, take out the Naza and GPS, put in the old KK2.0 card in it, and sell it. Take the Naza+GPS and put in a TBS Discovery.
    Is'nt that a nice solution?

  8. #8
    Buddy Box
    Join Date
    Nov 2012
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Talking

    Quote Originally Posted by kyrkbymannen View Post
    Thanks for all answers.

    What i'm going to do is, take out the Naza and GPS, put in the old KK2.0 card in it, and sell it. Take the Naza+GPS and put in a TBS Discovery.
    Is'nt that a nice solution?
    Good choice, is what I am in the process to do.

  9. #9
    Mr take no prisoners! PeteDee's Avatar
    Join Date
    Mar 2013
    Location
    Canberra, Australia
    Posts
    1,191
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by kyrkbymannen View Post
    Hello,

    I have built a hexacopter with a DJI Naza controller.
    It's got a DJI Hexacopter frame but with the following setup

    DJI Naza + GPS
    Hobbywing Pentium ESC
    Turnigy Propdrive 35-30 1100 KV (very strong)
    10x5 props which i've balanced a bit.

    The problem i have, although it flies excellent in manual mode, i cannot use the attitude mode, it climbs and drops and climbs and drops... and not a small amount either, atleast 2 - 3 meters. I have tried a bunch of gain settings,but i'm not sure the gain is the problem.
    I got me a program card for the ESC's , but i dont know if timing or break on off will make a difference?

    Anyone with experience in this?

    Thanks!

    So what settings are you using for all your gains?

    Pete
    Disco, Disco Pro, Spanky250, Q400-X
    DX18,14SG

  10. #10
    Pilot Extraordinaire
    Join Date
    May 2013
    Posts
    62
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Im having a similar problem. In manual mode my hexcopter flys just fine. But in atti mode it barely gets enuff power to take off, and seems to wobble on the ground as if its trying to correct its balance as if it was in the air. I can see individual props speed up as if its trying to level. Is my naza broken?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •